Hot Fix Deployment for Xero Issue

Incident Report for meddbase

Resolved

The Hot Fix has now been successfully deployed to all affected clients, and the issue is fully resolved.
Posted Nov 18, 2025 - 10:17 GMT

Monitoring

The Hot Fix has now been successfully deployed to most impacted clients, who should now be fully operational.

We are continuing to deploy the fix for a small number of remaining clients and will provide further updates once this process is complete.

Thank you for your patience and understanding as we work to ensure full resolution.
Posted Nov 18, 2025 - 10:03 GMT

Identified

We have identified an issue impacting our accountancy software, Xero.

A Hot Fix has been prepared and will be deployed shortly. This will only affect selected customers and may result in approximately 3 minutes of downtime for those impacted.

We sincerely apologise for any inconvenience this may cause and appreciate your understanding as we work to resolve the issue promptly.
Posted Nov 18, 2025 - 09:40 GMT
This incident affected: Critcal Services.