Service Interruption - Pathology Lab Results

Incident Report for meddbase

Resolved

Our engineering team have now confirmed that this issue has been fully resolved, Pathology Labs results are now processing as expected, but we are closely monitoring the system to ensure continued stability.
Posted Feb 26, 2026 - 11:17 GMT

Investigating

We are aware of an issue affecting our Pathology Labs integration and are actively investigating the cause.
Posted Feb 26, 2026 - 09:41 GMT
This incident affected: Critcal Services.