The issue has now been stabilised, and we will be implementing additional changes this evening to ensure it is fully resolved.
We will continue to monitor the situation closely until all updates have been completed.
Posted May 20, 2025 - 13:59 BST
Monitoring
We have now implemented the restart and are actively monitoring the situation to ensure it is resolved.
Posted May 20, 2025 - 10:54 BST
Identified
We are currently experiencing performance issues with our back-end databases, which may be causing timeouts for some UK customers. To resolve the problem, we will be performing a system restart. This may temporarily require some users to log back into the application. We are actively monitoring the situation and will continue to provide updates on this status page.
Posted May 20, 2025 - 10:27 BST
This incident affected: UK Environments (Application Access, Critical Services).