Meddbase UK Status Update: Issue
Incident Report for meddbase
Resolved
The issue affecting some of our UK environments with regards to the displaying of patient data has now been resolved and all data should be visible again.

We are continuing to monitor the situation.

We apologise for any inconvenience caused.
Posted Mar 22, 2024 - 11:23 GMT
Identified
We are aware of an issue affecting some of our UK environments with regards to the displaying of patient data.

Our engineers are investigating and will have an update soon.
Posted Mar 22, 2024 - 11:15 GMT
This incident affected: UK Environments (Non-Critical Services).