We identified an IO performance issue with our document storage platform, which has now been rectified, and full functionality has been restored. The incident is now considered resolved, but we will continue to monitor the system to ensure ongoing stability.
Posted Jul 02, 2025 - 18:08 BST
Investigating
We are aware of an issue affecting the ability of some customers to upload documents. This is being treated as a high priority incident and we are actively investigating.
Posted Jul 02, 2025 - 17:20 BST
This incident affected: UK Environments (Critical Services).