Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 09:00 GMT
Scheduled
The main Meddbase application will not be available for our Canadian & US customers during the times stated. This is part of our regular weekly maintenance schedule. We apologise for any inconvenience caused during this time.
Posted Nov 23, 2025 - 20:48 GMT
This scheduled maintenance affected: CA + US Environments (Application Access, Critcal Services, Non-Critical Services).