Issue with Opayo/SagePay Payments
Incident Report for meddbase
Resolved
Card and online payments have been restored.
A change to the Elavon / Opayo URLs resulted in an unexpected switch in security standards. This required an internal infrastructure change.
We apologise for any inconvenience caused.
Posted Mar 26, 2024 - 09:56 GMT
Investigating
We are currently investigating
Posted Mar 26, 2024 - 08:58 GMT
This incident affected: UK Environments (Critical Services), EU Environments (Critcal Services), and CA Environments (Critcal Services).