Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2023 - 22:30 GMT
Scheduled
The Meddbase application will not be available to our UK and EU users during the times stated. This is due to the deployment of urgent maintenance to resolve an incident impacting some users over the last 2 days. We apologise for any inconvenience caused during the time.
Posted Dec 01, 2023 - 18:46 GMT
This scheduled maintenance affected: UK Environments (Application Access, Critical Services, Non-Critical Services) and EU Environments (Application Access, Critcal Services, Non-Critical Services).