Meddbase UK Status Update: Issue
Incident Report for meddbase
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 23:06 BST
Investigating
We are experiencing issues with one of our databases resulting in degraded performance for some systems.
Posted Jun 23, 2023 - 22:25 BST
This incident affected: UK Environments (Application Access, Critical Services, Non-Critical Services).