We now have confirmation that application access for EU environments has been restored.
The server failure was caused by a Microsoft Azure outage for Northern Europe, which has now been resolved.
Posted Apr 01, 2025 - 11:06 BST
Identified
We have identified the issue as a failure of a server which has lost connection to its internal storage. Our team is actively exploring workarounds and coordinating with Azure Support to understand the cause of the issue.
Posted Apr 01, 2025 - 10:48 BST
Investigating
We are aware of an issue currently affecting clients' ability to access the main Meddbase application on our EU servers. This is currently being investigated as a top priority.
Posted Apr 01, 2025 - 09:58 BST
This incident affected: EU Environments (Application Access).