Performance issues

Incident Report for meddbase

Resolved

The immediate issue has been mitigated and we are seeing performance level return to normal
Posted Sep 18, 2024 - 17:05 BST

Investigating

We are aware of performance issues impacting some UK sites and are currently investigating
Posted Sep 18, 2024 - 16:31 BST
This incident affected: UK Environments (Application Access).