Meddbase UK Status Update: Issue

Incident Report for meddbase

Resolved

This incident has been resolved.
Posted Dec 06, 2023 - 22:49 GMT

Update

We have tracked down the cause and are making changes to rectify it.

Please use Firefox Browser as a temporary workaround as the issue has been isolated to Google Chrome and Mircosoft Edge.

Thank you for your patience while we resolve this
Posted Dec 06, 2023 - 13:31 GMT

Identified

We are aware of an ongoing issue affecting the signing and dispensing of E-Prescriptions. This is being investigated by our engineers.

An update will be provided as soon as one becomes available.

We apologise for any inconvenience.
Posted Dec 05, 2023 - 17:44 GMT
This incident affected: UK Environments (Non-Critical Services).