Application performance issues

Incident Report for meddbase

Resolved

The solution we implemented has successfully mitigated the issue, and all clients should be able to access the system without further problems. The incident is now considered resolved, but we will continue to monitor the system to ensure ongoing stability.
Posted Aug 01, 2025 - 12:52 BST

Monitoring

We have taken actions that appear to have addressed the performance issue. Initial results indicate considerable performance improvements, but we are closely monitoring the system to ensure continued stability.
Posted Aug 01, 2025 - 12:09 BST

Update

We're continuing to investigate the root cause of the issue and are running a number of processes to help stabilise performance. You may still experience slower response times while this work is ongoing. We're monitoring the situation closely and will provide further updates as we make progress.
Posted Aug 01, 2025 - 11:27 BST

Update

Our team is actively investigating the issue and continuing to work through potential causes. We’ve taken several steps so far, including recycling key systems, but the issue persists. Please rest assured that resolving this remains our top priority.
Posted Aug 01, 2025 - 10:46 BST

Investigating

We are aware of a performance issue affecting some UK customers and are actively investigating the cause.
Posted Aug 01, 2025 - 10:10 BST
This incident affected: UK Environments (Application Access, Critical Services, Non-Critical Services).