Appointment Amendments
Incident Report for meddbase
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 22:47 BST
Monitoring
We are aware of an issue that is currently affecting some clients ability to amend appointments and plan to release a fix this evening at 10.30pm that will rectify this issue. Please accept our apologies for any inconvenience caused to you and your clients during this time.
Posted Oct 22, 2024 - 11:49 BST
This incident affected: UK Environments (Non-Critical Services) and EU Environments (Non-Critical Services).