SMS performance
Incident Report for meddbase
Resolved
Functionality is restored.
Posted Sep 11, 2024 - 11:13 BST
Investigating
We are aware of SMS issues impacting some UK sites and are currently investigating
Posted Sep 11, 2024 - 10:51 BST
This incident affected: UK Environments (Non-Critical Services).