Meddbase EU: Unable to login

Incident Report for meddbase

Resolved

The issue only affected one client on EU.
Posted Mar 27, 2025 - 08:23 GMT

Investigating

We are aware of an issue where our EU customers are unable to login to meddbase.

This is currently being investigated.
Posted Mar 27, 2025 - 07:59 GMT
This incident affected: EU Environments (Application Access, Critcal Services, Non-Critical Services).