External emails into Meddbase blocked.
Incident Report for meddbase
Resolved
Service has been restored and emails from external sources are no longer being blocked by our firewalls.

We apologise for any inconvenience caused. Feel free to raise a ticket with our helpdesk if you have any questions or concerns.
Posted Jan 03, 2023 - 10:40 GMT
Update
We are continuing to work on a fix for this issue.
Posted Jan 03, 2023 - 09:47 GMT
Identified
Currently, external emails into the main Meddbase application are being blocked. We are aware of the issue and our engineers are investigating.

Updates to be provided as soon as more become available.
Posted Jan 03, 2023 - 09:35 GMT
This incident affected: UK Environments (Critical Services), US Environments (Critcal Services), CA Environments (Critcal Services), and EU Environments (Critcal Services).